Repository navigation
ci: pick the e2e driver version compatible with the Appium server - #2490
Merged
Merged
Conversation
The resolver paired stable server 3.9.0 with driver 9.0.1, which requires Appium ^4.0.0-beta.6, so driver installation failed. The driver is now chosen by its `appium` peer range against the resolved server version. Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
mykola-mokhnach
requested review from
SrinivasanTarget,
saikrishna321 and
valfirst
as code owners
November 2, 2026 11:12
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Problem
The e2e version resolver used the beta server and driver only if both betas were newer than their stable releases. With server beta
4.0.0-beta.7but driver beta9.0.0-beta.2(older than stable9.0.1), it picked stable server3.9.0with driver9.0.1, which requires Appium^4.0.0-beta.6, soappium driver installfailed (seen in #2487). The--stableFlutter jobs were affected too.Fix
Pick the driver from its
peerDependencies.appiumrange against the resolved server: the beta server is used if it is newer than stable and some driver supports it; otherwise the stable server is used with the newest compatible stable driver.Resolved today: default → appium 4.0.0-beta.7 + uiautomator2 9.0.1 / xcuitest 13.0.3;
--stable→ appium 3.9.0 + uiautomator2 8.7.3 / xcuitest 12.22.8.